How do | configure Eclipse for Fedora with Maven?

Daé)ecated Document

ThiS™document is being revised. Fedora development has now moved to Git and the sources are hosted on GitHub. The Subversion-related content of this
article is no longer valid. There is a separate article on Git integration including Maven. However, a number of other Eclipse configuration instructions are
not covered in that article. So the two article are being merged. Further, Eclipse has now released Indigo that incorporates M2Eclipse with direct support of

git.

Eclipse is a popular integrated development environment (IDE) which is used by many developers for the Fedora Repository service, clients and other
related services. You do not need to build the Fedora Repository from source in Eclipse in order to build your own projects though it may be convenient.
You may build the Fedora Repository from the command line and just use Eclipse for editing and debugging. The options are too numerous for one article
so we will describe just a few popular configurations to get you started.

The current Fedora Repository trunk (Fedora 3.3 and greater) uses Apache Maven for building the source. Maven helps manage dependencies and
makes project information readily available. You can build Fedora using Maven from the command line or within Eclipse. Like Eclipse, Maven is based on
the idea of using "convention over configuration." While Maven is very flexible, it promotes good modularization practices which should make using Eclipse
for Fedora easier.

Fedora development has now moved to Git and the sources are hosted on GitHub.

This article uses the Fedora Repository service as an example. It is important that you read the Installation and Configuration Guide first. It contains a
significant amount of information about the Fedora Repository and building it from source which is not repeated here. Fedora has been built using the last
three releases of Eclipse however this article uses Indigo, the latest release, as an example. Use of Indigo has substantial advantages since Maven
support through m2e plug-in (formerly called M2Eclipse) is fully integrated with Git support (through the EGit plug-in).

Ec&j;e Helios

TheTe is a known problem which causes lockup with the Sun JDK 1.6.0_21 but is resolved in the current Helios download and also has a manual
workaround. Note that this problem still exists in Galileo and Ganymede. We have performed a successful build from Helios on Ubuntu Linux, Window XP
and Windows 7 with Git and M2Eclipse installed.

On this page:

Installing the JDK

Install Eclipse

Select the JDK and Set the Compiler Compliance

Configure Maven

Install a Subversion Client

Install the M2Eclipse Plug-in

Create an Eclipse Project

Customize the Workspace Settings
© To set up Eclipse (Helios, Galileo and Ganymede):
O Optional Settings

® |nstalling from the Command-Line

© Known Issues

© Related Materials

o Eclipse with Maven notes

Installing the JDK

Fedora is only tested with the Sun JDK though others may work well or even be required for a particular operational environments such as specific
application servers. Eclipse has a very sophisticated structure which supports the installation and use of multiple Java compilers and run time
environments. Initially, we recommend installing the Sun JDK to get success and then you may explore other options.

The Oracle/Sun JDK may be obtained from here for common platforms. Fedora is developed using Java 1.6. It is not required that Eclipse be running in
the same JDK/JRE version as is being used for development but it is convenient if you use the same JDK/JRE version on the command line as you are
using for Eclipse. Note that a JDK is required for some operations of the M2Eclipse plug-in described below.

It is also convenient for you install the JDK outside "Program Files" if you are developing in Microsoft Windows, using a directory with no spaces in the
name. Eclipse and the Fedora command-line Maven-based build tools will work with proper set-up but you will have less trouble if you avoid directories
with spaces in their names. Also, very long directory structures may be found in Eclipse projects and generally don't cause problems with Eclipse, but may
cause problems with other products in Windows XP. So having a top-level Wor kspaces directory is helpful.

Install Eclipse

Download and install Eclipse. You may install any package since you can add plug-ins later but it is convenient to install the "Eclipse IDE for Java EE
Developers" since it already contains most of the plug-ins you may want to use. It is recommended that you install the JDK separately since you may wind
up using several versions.

Select the JDK and Set the Compiler Compliance


http://maven.apache.org
https://wiki.lyrasis.org/display/FEDORA37/Installation+and+Configuration
http://www.infoq.com/news/2010/07/eclipse-java-6u21
http://www.oracle.com/technetwork/indexes/downloads
http://www.eclipse.org/downloads/

Make sure Java 1.6 appears as an installed JRE and that it is the default JRE for the project.

A) Use the Eclipse Menu: Window -> Preferences -> Java ->
Installed JREs. Despite the name of the menu item it is highly
recommended that you install JDKs. Use of a JDK is required for the
M2Eclipse Maven plug-in described below. Use the Add button to
add the Java 1.6 JDK if it is not already installed. Check the Java 1.6
JDK and press OK.
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B) Use the Eclipse Menu: Window -> Preferences -> Java ->
Compiler. Select 1. 6 in the Conpi | er conpliance |evel:
combo box and press Appl y.

Jed x|
Torvgalar LT
& Sarera a S
& ini = STEEAT Sk oo T
i etz Fnamrat T Cormplal e
- ConphY 0 FELN0 it [ =
t :' Al 17 | na el o b
a1
o ApEaN HS j
= Bk e =
e fenta e
Sezcder Lrv el vamable s 1o g e daes s uees by e debuge)
L i e rmmnber ST 10 e e e e By e cetmige) o
[em— .
1 ::::" e 5 ek e fls o e o gereraned i i s by e dsbgoer)
b Ty Parccencs [ Prwurs unumes (rercer raacilacl onabier
———— F
& Fug-n Deslopmar 5
T [ ! L
: .

Configure Maven

The M2Eclipse plug-in includes an embedded Maven. Optionally you can also install Maven on the command-line. Regardless, you must have a local
Maven repository to cache dependencies and work products from the builds. A command-line Maven can be obtained from http://maven.apache.org/. If
Eclipse cannot find the local Maven repository you will have ugly errors and Eclipse may lock-up.

Duraspace provides a Maven repository for Fedora dependencies which cannot be obtained from Maven Central or common public Maven repositories.
You do not have to do anything to use this repository, everything is handled by Maven from specifications in the POMs.

Maven will look for the repository in several standard locations. However, you can make things easier if you create a setting file. Settings may be obtained
globally from the Maven installation or in a settings file associated with your user. The user settings file varies depending on the operating system (in
Windows - "Documents and Settings\username\.m2\settings.xml", in Linux - "home/username/.m2/settings.xml"). The global setting file is usually in
<maven-install>/conf. If you install a command-line Maven you may accidentally wind up with two local Maven repositories. Just make sure everything
points to the same local repository. If you have problems may help to set the environment variable M2_HOME to <maven-install> and put <M2_HOME>
/bin on your path.

Example user settings.xml

<settings xm ns="http://maven. apache. org/ SETTI NGS/ 1. 0. 0"
xm ns: xsi ="http://ww. w3. or g/ 2001/ XM_Schena- i nst ance"
xsi : schemaLocati on="http:// maven. apache. org/ SETTI NGS/ 1. 0. 0
http:// maven. apache. or g/ xsd/ setti ngs-1. 0. 0. xsd">
<l ocal Reposi tory>d:/ n2/repository</|ocal Repository>
</settings>


http://maven.apache.org/

Example global settings.xml

<?xm version="1.0" encodi ng="UTF-8"?>

<I--

Li censed to the Apache Software Foundati on (ASF) under one
or nore contributor |icense agreenents. See the NOTICE file
distributed with this work for additional infornation
regardi ng copyri ght ownership. The ASF licenses this file
to you under the Apache License, Version 2.0 (the
"License"); you may not use this file except in conpliance
with the License. You nay obtain a copy of the License at

http://ww. apache. org/licenses/ LI CENSE- 2. 0

Unl ess required by applicable |aw or agreed to in witing,
software distributed under the License is distributed on an
"AS | S" BASIS, W THOUT WARRANTI ES OR CONDI TI ONS OF ANY
KIND, either express or inplied. See the License for the
speci fic | anguage governing pernissions and |linitations
under the License.

-->

<l--
| This is the configuration file for Maven. It can be specified at two |evels:

1. User Level. This settings.xm file provides configuration for a single user,
and is normally provided in ${user.home}/.n2/settings.xm .

NOTE: This location can be overridden with the CLI option:
-s /path/to/user/settings.xmn

|

|

|

|

|

|

|

|

| 2. dobal Level. This settings.xm file provides configuration for all Maven
| users on a machine (assuning they're all using the sane Maven
| installation). It's normally provided in

| ${ maven. hone}/ conf/settings. xm .

|
|
|
|
|
|
|
|
|

NOTE: This location can be overridden with the CLI option:
-gs /path/to/global/settings.xm

The sections in this sanple file are intended to give you a running start at
getting the nost out of your Maven installation. Where appropriate, the default
val ues (val ues used when the setting is not specified) are provided.

|-->
<settings xm ns="http://maven. apache. or g/ SETTI NGS/ 1. 0. 0"
xm ns: xsi ="http://ww. w3. or g/ 2001/ XM_Schena- i nst ance"
xsi : schemaLocati on="http://maven. apache. org/ SETTI NGS/ 1. 0. 0 http:// maven. apache. or g/ xsd/ settings-1.0.0.
xsd" >
<!-- local Repository
| The path to the local repository maven will use to store artifacts.
|
| Default: ~/.nR/repository
<l ocal Reposi tory>/ path/to/local /repo</| ocal Repository>
-->
<l ocal Reposi tory>d:/ n2/repository</|ocal Repository>

<l-- interactiveMde

| This will determ ne whether maven pronpts you when it needs input. If set to false,
| maven will use a sensible default value, perhaps based on sone other setting, for

| the paraneter in question.

|

| Default: true

<interactiveMde>true</interactiveMde>

-->

<l-- offline



| Deternines whether maven should attenpt to connect to the network when executing a build.
| This will have an effect on artifact downl oads, artifact deploynment, and others.
[

| Default: false
<of fli ne>fal se</of fline>
-->

<!-- plugi nG oups
| This is a list of additional group identifiers that will be searched when resol ving plugins by their
prefix, i.e.

| when invoking a command line like "nvn prefix:goal”. Maven will automatically add the group identifiers
| "org.apache. maven. pl ugi ns" and "org. codehaus. nojo" if these are not already contained in the |ist.
|-->

<pl ugi nG oups>
<!-- pluginGoup
| Specifies a further group identifier to use for plugin |ookup.
<pl ugi nG oup>com your . pl ugi ns</ pl ugi nG oup>
--2>

</ pl ugi nG oups>

<!-- proxies
| This is a list of proxies which can be used on this machine to connect to the network
| Unless otherw se specified (by systemproperty or command-line switch), the first proxy
| specification in this list marked as active will be used
|-->
<pr oxi es>
<!-- proxy
| Specification for one proxy, to be used in connecting to the network
|
<pr oxy>
<i d>optional </id>
<active>true</active>
<protocol >htt p</protocol >
<user nanme>pr oxyuser </ user name>
<passwor d>pr oxypass</ passwor d>
<host >pr oxy. host . net </ host >
<port>80</ port>
<nonPr oxyHost s>l ocal . net | sone. host. conx/ nonPr oxyHost s>
</ pr oxy>
>
</ pr oxi es>

<l-- servers
| This is a list of authentication profiles, keyed by the server-id used within the system
| Authentication profiles can be used whenever naven nust make a connection to a renote server.
|-->
<servers>
<I-- server
| Specifies the authentication information to use when connecting to a particular server, identified by
a unique nanme within the system (referred to by the 'id attribute bel ow).

|
|
| NOTE: You shoul d either specify usernane/ password OR privat eKey/ passphrase, since these pairings are
| used together.
|
<server>
<i d>depl oynent Repo</i d>
<user nanme>r epouser </ user nane>
<passwor d>r epopwd</ passwor d>
</ server>
-->

<I-- Another sanple, using keys to authenticate.

<server>
<i d>siteServer</id>
<privat eKey>/ pat h/ to/ pri vat e/ key</ pri vat eKey>
<passphrase>optional; |eave enpty if not used.</passphrase>

</ server>

-->

</ servers>

<l-- mrrors



This is a list of mirrors to be used in downl oading artifacts fromrenote repositories.

|

|

| It works like this: a POM may declare a repository to use in resolving certain artifacts.

| However, this repository may have problenms with heavy traffic at times, so people have mirrored
| it to several places.
|
|
|
|

That repository definition will have a unique id, so we can create a mrror reference for that
repository, to be used as an alternate download site. The nmirror site will be the preferred
server for that repository.
|-->
<m rrors>
<l-- mrror
| Specifies a repository mirror site to use instead of a given repository. The repository that
| this mirror serves has an ID that matches the mirror( elenent of this mrror. |IDs are used
| for inheritance and direct |ookup purposes, and nust be unique across the set of mirrors.
|
<m rror>
<id>mirrorld</id>
<m rrorf >repositoryld</mrrorOf >
<nane>Human Readabl e Name for this Mrror. </ name>
<url >http://ny.repository.com repo/ path</url >
</mrror>
-->
</mrrors>

<l-- profiles

| This is a list of profiles which can be activated in a variety of ways, and which can nodify
the build process. Profiles provided in the settings.xnl are intended to provide |ocal machine-
specific paths and repository locations which allow the build to work in the local environnent.

For exanple, if you have an integration testing plugin - like cactus - that needs to know where
your Tontat instance is installed, you can provide a variable here such that the variable is
dereferenced during the build process to configure the cactus plugin.

|

|

|

|

|

|

|

| As noted above, profiles can be activated in a variety of ways. One way - the activeProfiles

| section of this docunent (settings.xml) - will be discussed |ater. Another way essentially

| relies on the detection of a systemproperty, either matching a particular value for the property,
| or merely testing its existence. Profiles can also be activated by JDK version prefix, where a

| value of '"1.4'" mght activate a profile when the build is executed on a JDK version of '1.4.2_07'.
| Finally, the list of active profiles can be specified directly fromthe conmand |ine.

|
|
|
|
|

NOTE: For profiles defined in the settings.xm, you are restricted to specifying only artifact
repositories, plugin repositories, and free-form properties to be used as configuration
variables for plugins in the POM

|-->
<profil es>
<l-- profile
| Specifies a set of introductions to the build process, to be activated using one or nore of the
mechani sns descri bed above. For inheritance purposes, and to activate profiles via <activatedProfiles/>
or the comrand line, profiles have to have an ID that is unique.

|

|

|

| An encouraged best practice for profile identification is to use a consistent nam ng convention

| for profiles, such as 'env-dev', 'env-test', 'env-production', 'user-jdcasey', 'user-brett', etc.
| This will nmake it nmore intuitive to understand what the set of introduced profiles is attenpting
| to acconplish, particularly when you only have a list of profile id s for debug.

|
|

This profile exanple uses the JDK version to trigger activation, and provides a JDK-specific repo.
<profile>
<i d>j dk- 1. 4</i d>

<activation>
<j dk>1. 4</j dk>
</ activation>

<repositories>
<r eposi tory>
<i d>j dk14</id>
<name>Repository for JDK 1.4 buil ds</name>
<url>http://ww. nyhost. com maven/j dk14</url >
<l ayout >def aul t </ | ayout >



<snapshot Pol i cy>al ways</ snapshot Pol i cy>
</repository>
</repositories>
</profile>
--2>

<l--
| Here is another profile, activated by the system property 'target-env' with a value of 'dev',
| which provides a specific path to the Tontat instance. To use this, your plugin configuration
| might hypothetically look Iike:
|
| ...
| <pl ugi n>
| <gr oupl d>or g. nyco. nypl ugi ns</ gr oupl d>
| <artifact!ld>nmypl ugin</artifactld>
|
| <configuration>
| <t ontat Locat i on>${t ontat Pat h} </ t ontat Locat i on>
| </ configuration>
| </plugin>
|
|
| NOTE: If you just wanted to inject this configuration whenever soneone set 'target-env' to
| anyt hing, you could just |eave off the <value/> inside the activation-property.
|
<profil e>

<i d>env-dev</id>

<activation>
<property>
<nane>t ar get - env</ name>
<val ue>dev</ val ue>
</ property>
</ activation>

<properties>
<t ontat Pat h>/ pat h/ t o/ t ontat /i nst ance</ t ontat Pat h>
</ properties>
</profile>
-->
</profiles>

<I-- activeProfiles
| List of profiles that are active for all builds.
|
<activeProfil es>
<activeProfil e>al waysActiveProfile</activeProfil e>
<activeProfil e>anot her Al waysActi veProfil e</activeProfile>
</ activeProfil es>
-->
</settings>

Install a Subversion Client

It is recommended that you install a Subversion plug-in, either Subversive or Subclipse (use only one or bad things will happen), even if you only intend to
build from the command-line. Installing a Subversion plug-in enables you to see the history of files and often is required for advanced functions of other
plug-ins. Unfortunately, some plug-ins may work only with Subversive or Subclipse but not both. Please provide comments on this article regarding your
experience.

A Subversion plug-in is required for a number of functions in the Maven plug-in M2Eclipse described below. Subclipse is provided by the same
organization as M2Eclipse however Subversive integration with M2Eclipse is available and in our testing seems to support all common operations. Also,
Subversive is the incubated Eclipse plug-in.

Many developers use a command-line svn or graphical Subversion client such as Tortoise as their primary SCM client. Building from the command-line
and using Eclipse primarily for editing, debugging, and other functions is a common approach for developing Fedora Commons projects (see Building the
Fedora Repository). However, it is still very helpful to have a Subversion plug-in installed. One Maven plug-in we use to automatically creates build
numbers, bui | dnunber - maven- pl ugi n, and depends on having a command-line Subversion available, but will only generate a warning which can be
ignored if one is not present.


http://www.polarion.com/products/svn/subversive/download.php?utm_source=eclipse.org&utm_medium=link&utm_campaign=subversive
http://subclipse.tigris.org/
http://www.open.collab.net/downloads/subversion/
http://tortoisesvn.tigris.org/

In the following example we show the steps for using Subversive. Installing Subversive is a bit complicated and is changing as it is moving through Eclipse
incubation. Once you have installed a Subversion client the following steps may be used to customize your Eclipse settings and to link to the Fedora
Subversion repository. Note that some of the steps can only be accomplished after you have downloaded the Fedora sources preferably using Subversion.
Don't worry, just get them done before you start editing or building the code.

A) Use the Eclipse Menu: Window -> Open Perspective -> Other.
Using the Open Per spect i ve dialog select SVN Repository
Expl ori ng and press Appl y.

F Open Perspective

=S Renceitory Explarng
(e Danzhse Debug

(B Datehase Devdopmernt
*‘i'rl x=big

BNava

=ava Browsrg

12 Java EE

12! Java Type Hierarchy

B Javasoipt

A JFA

CFETIrg

A Flug-n Deseloprient

iR emabe Systern Explorer
[oResource [defaclt)

w0 SV Repesltory Explaring
&' Team Synchronizing

@ el

Cance

B) Use the right-mouse click menu or the Eclipse Menu: File -> New -
> Repository Location. Enter the URL of the Subversion repository
(no authentication is needed to download), optionally add a custom
label and press OK.
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C) Currently the Fedora Repository Project Subversion repository is
located at: https://fedora-commons.svn.sourceforge.net/svnroot
/fedora-commons/fedora on Sourceforge.net. After you have
successfully define the repository location you should be able to see
its trunk, branches, and tags.

1) S¥N Repositories
fiy &
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@08 ROOT 7906
L s REVISIONS

D) Use the Eclipse Menu: Window -> Preferences -> Team -> SVN -
> Properties Configuration. On the Aut onati ¢ Properti es tab
import r esour ces/ devdocs/ devenv/ subver si on. confi g from
the Fedora Repository sources and press Appl y. Please note, its
best to do this step later after you have installed M2Eclipse and
downloaded the project.


https://fedora-commons.svn.sourceforge.net/svnroot/fedora-commons/fedora
https://fedora-commons.svn.sourceforge.net/svnroot/fedora-commons/fedora
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Install the M2Eclipse Plug-in

There are Eclipse targets built into Maven but the M2Eclipse from Sonatype provides a capable and well documented addition to your Eclipse IDE. It is
highly recommended that you install it. The installation is well documented and there is an online book Developing with Eclipse and Maven that is highly
recommended reading. Note that the installation process only documents the use of Subclipse, another Sonatype contribution. However, there is a
Subversive integration available which in our testing supports common used M2Eclipse functionality (you must install the Subver si ve I ntegrati on
for the MEclipse Project plug-in here).

M2Eclipse will complain if you are not running Eclipse within a JDK are instead using a stand-alone JRE. This will require you to edit the ecl i pse. i ni file
found in top-level director of your Eclipse installation. The formatting of this file is tricky and unforgiving. Below is an example from a Windows installation:

-startup

pl ugi ns/ org. ecli pse. equi nox. | auncher _1. 0. 200. v20090520. j ar
--launcher.library

pl ugi ns/ org. ecl i pse. equi nox. | auncher . w n32. wi n32. x86_1. 0. 200. v20090519
- product

org. ecl i pse. epp. package. j ee. product

- -l auncher . XXMaxPer nfi ze

256M

- showspl ash

org.eclipse.platform

- -l auncher . XXMaxPer nSi ze

256m

-vm

c:/javaljdkl.6.0_13/bin/javaw. exe

-vmargs

- Dosgi . requi redJavaVer si on=1. 6

- Xnms512m

- Xmx1024m

Create an Eclipse Project

You must create an Eclipse project for Fedora. The layout of the Fedora Repository source pre-dated the use of Eclipse and does not follow the most
natural layout for Eclipse projects. However, Eclipse can be configured to be an effective IDE for development. The ongoing refactoring for Maven is

making it more natural to build using Eclipse and enabling the use of Eclipse plug-ins. There are actually too many ways to configure Eclipse for us to
document here. We will, however, illustrate one common configuration which you may use (and challenge the community to add more options to this

article).

Eclipse Friendliness

1
Refactoring of Fedora is underway to improve modularity which will help make Fedora more Eclipse friendly. Code sections have been entirely
restructured to build with Maven. However, there is still work to be done in refactoring Fedora to improve modularity. You can follow this ongoing effort now
in this Wiki and JIRA. The work at ANT to Maven2 is concluded.

There is an easy way to create the Fedora Repository project with M2Eclipse. First you must specify the repository location using the SVN Repository
Exploring perspective. Then using the Checkout as Maven Project wizard you will create the f edor a- r eposi t or y project and import the source code.
As a prerequisite, we assume you have already successfully configured the Subversion client in Eclipse, installed M2Eclipse and configured your local
Maven repository. The following example uses the Subclipse plug-in.


http://m2eclipse.sonatype.org/
http://www.sonatype.com/products/m2eclipse/documentation
http://community.polarion.com/projects/subversive/download/integrations/update-site/
https://wiki.lyrasis.org/display/FCREPO/ANT+to+Maven2

. Set up the Subversion Repository

. Select the trunk or the branch with which you wish to work

. Use the Check Qut as Maven Project Wizard

. Create a Maven Run As Maven Bui | d configuration

. Usethe Run As Maven Bui | d configuration to build the project the first time

O wWNPRE

Set Up the Source Repository and Create the Project

A) In a fresh install of Eclipse you will see the Welcome screen. It will
help if you use the Eclipse Menu: Project -> Build Automatically to
uncheck this function. We will use the Maven build for the first build
of the repository.

B) Using the Eclipse Menu: Select the Window -> Open Perspective -
> SVN Repository Exploring open the perspective.
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C) You should see the following perspective:

EXY TETCR r a4
e
ST




D) Right click in SVN Reposi tori es view to display the Add SVN
Reposi t ory dialog. Use the URL https://fedora-commons.svn.
sourceforge.net/svnroot/fedora-commons/fedora.

Add a new SVN Repository
A0 & e SR Reposiony D Te Sk ezl e

HftTes L Mdara fn i S son e . s bladnea o one R ions |

E) Open the repository and select the trunk or a desired branch. This
may take some time depending on the response of the Subversion
repository.

F) Right click to display the SVN menu and select Check out as
Maven Project. ..

o



https://fedora-commons.svn.sourceforge.net/svnroot/fedora-commons/fedora
https://fedora-commons.svn.sourceforge.net/svnroot/fedora-commons/fedora

G) Select the target location and revision. If you do not see svn as a
choice in the SCM URL combo box Subclipse is not correctly set up.
Dialogs for Subversive may be different. If you have only one
repository, the dialog will already be populated. Otherwise select the
Fedora Subversion repository URL. Typically you will check out the H
ead Revisionand Check out All projects. Openthe Advan
ced drop down and select Resol ve Wor kspace Proj ects and Se
parate projects for nodul es. This will create a separate
Eclipse project for each Maven pom which you may find useful later.
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H) Select the Next > button to display the Sel ect Proj ect
Locat i on dialog. It is a personal preference where the workspace
will be created on your workstation. If you have other project in the
same workspace you may want to set up a working set just for the
Fedora Repository (e.g. fcrepo) though you can to this later too.
Select the Fi ni sh button and the wizard will complete its
operations. This may take some time because the wizard must
create the Eclipse project(s), download the sources, and download
the Maven dependencies to your local repository. If this process
seems to hang you may be having problems with the configuration of
your local Maven repository. If this happens you may be able to kill
Eclipse, correct the problem and use the Updat e Maven
Dependenci es feature of M2Eclipse. Otherwise, delete the project

and start again using the Check out as Maven Project...
wizard.
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Set up the Maven Run As Confi gurati on and Build the Project

1) Switch to the Java perspective to set up the run configurations.

»

|GoogE
%F Debug

Hesolrce
i SV Repository Exploring
¢® JavaEE




J) You will notice a number of projects, one for each Maven pom.
Using this approach lets you make Eclipse settings for each module.
The name of the top-level project is automatically set to f cr epo and
M2Eclipse will have already make key Eclipse project settings for
you.
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K) There are two ways to create a new Run Conf i gur ati on from
the Java perspective. You can right click on the f cr epo project to
start the new Run Conf i gur at i on dialog.
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L) Alternately, you can use the Eclipse Menu: Run -> Run
Configurations ...
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M) Start the Maven Run Conf i gur at i on dialog using a right click
on Maven Bui | d and selecting the new menu item.
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N) You will see the Run Conf i gur ati on dialog. Using a Maven
run configuration is exactly the same as running a Maven build from
the command line. Later we will show how to use more of the Eclipse
build features but for the first build lets use a basic run configuration.
Give the configuration a name, set the base directory and the goals
which build the entire repository. Press the Appl y button to save the
configuration (notice the name will be added to the list of Maven run
configurations in the left panel of the dialog.
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O) Check that the JRE is set to the Sun Java 1.6 initially. After you
have a successful build you may also want to build and test under
other JREs. Press the Appl y button to save the configuration and
press the Run button to start the build.



P) Since Fedora uses generated code and Maven will update the
project structure it is helpful to refresh the project display after each
build. This may not be fully sufficient so you also may need to update
select Maven configurations after a build (see Update Maven Projects)

Q) You can add additional Maven run configurations for individual
modules, other goals and integration tests. Note for the integration
tests you will need a compatibly configured running Fedora
Repository.
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R) Congratulations! You have succeeded in you first Maven build of
Fedora.
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S) Update Maven Configuration

Since Fedora uses generated code and Maven will update the project structure it is sometime necessary to manually update selected projects helpful.
After the first build and if there are any changes to the common or generated code right click on the conmon and f edor a- admi n- ¢l i ent projects. Use
the Maven -> Update Maven Configuration menu item to refresh the project.
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M2Eclipse has a number of options for deploying projects but its handling of hierarchical projects is not complete. Since Fedora is a hierarchical project, it
takes a little experience but Eclipse will work properly if permitted. Using the default M2Eclipse configuration is best. It presents subproject POMs as
ordinary appropriate (usually Java) Eclipse projects in the workspace separately for each POM. It you use this configuration, the Eclipse functionality will
work well. However, you will see both the hierarchical POM projects and the Java Projects in the project explorer views. If you look at the source directly
you will see a normal directory hierarchy. M2Eclipse will use information from the POM to create functional Eclipse projects (setting up the .project and .
classpath files). You can build equally using Eclipse Maven configuration or from the command line.

Customize the Workspace Settings

It is helpful if you customize the workspace settings. The coding standards settings are agreed to by the committers. Contributors are asked to use of the
same settings if possible to help facilitate the acceptance process. You will have customize the workspace setting each time you create a new workspace
or use the Copy Wor kspace Setti ng feature once you have your first workspace set up. Many of the settings can be loaded from files in the source
distribution. To set up your workspace (code style settings, etc):

® See resources (Fedora post 3.3) <fedora-repository>/resources/doc/devdocs/devenv/README.txt
The next video shows how to prepare the Eclipse IDE for development of the Fedora Repository source code.

This video was prepared using Europa but generally will work for Eclipse Galileo and Ganymede also. There are small differences in the IDE versions and
their dialogs. These instructions and screen images below were prepared with Ganymede and we are adding Galileo.

To set up Eclipse (Helios, Galileo and Ganymede):

It is recommended that you use to Eclipse Helios or Galileo (this section has been tested for Helios and Galileo - some small differences will be
encountered). You must install Eclipse and a compatible Java JDK prior to beginning this configuration. Also you need to obtain a set of configuration files
which are located in the Fedora Repository source.

A) Use the Eclipse Menu: Window -> Preferences -> Java -> Code Style

Under the top-level Code St yl e section:



T ol

W T Cade Skyla = S
=

-

_—— Elare Pt Socke Sebriz..

L R TEET e

= Dok AL
= el
= A e
- lasw
= LadH O
= ekt
= L by
hai
o el ™ Uem & prwle G sy s e =
|kl e P TR RUTRT P
Crorua ez
B Lorohe Ly raddeate o ol o

= Jasall
= laabowan: O
= boadn S|

]

I —
= e e

= Funlstug

iy ——

gl o | Fovoee 0ot ke
7 ===

1. Check "Add @Override ...", and leave other checkboxes unchecked
2. Make sure "Exception variable name" is e

B) Import the configurations files for the G ean Up, Code Tenpl at es, For matt er and Or gani ze | nport s from the bui | d directory in the Fedora
Repository source.
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4. Under the For mat t er section import f edor a-f or matt er. xnl and press Appl y
5. Under the Or gani ze | nport s section import fedora.importorder and press Appl y

. Under the C ean- up section import f edor a- cl eanup. xm and press Appl y
. Under the Code Tenpl at es section import f edor a- codet enpl at es. xm and press Appl y
3. Also under the Code Tenpl at es section in Comrent s - > Types edit Types to replace "Firstname Lastname" with your own name and press A



C) Use the Eclipse Menu: Window -> Preferences -> Java -> Editor -> Save Actions

1. Select "Perform the selected actions on save"
2. Make sure "Additional Actions" is selected
3. Click "Configure...", and go to the "Code Organizing" tab, and make sure "Remove trailing whitespace" and "All lines" are selected
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Optional Settings

Fedora makes use of WSDL generated Java classes. Without these, Eclipse will complain loudly. There are problems with refreshing in Eclipse that make
generated code a source of some difficulties. Also, the Eclipse builder provides substantial feedback such as errors and warnings that can aid in coding
but can also be overwhelming.

A) Use the Eclipse Menu: Window -> Preferences -> Team -> Ignored Resources

Addtarget,.settings,.classpathand. project and press the Appl y button.
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B) In the Problems view add a filter for warnings and errors. Use the Conf i gur e Cont ent s menu item. Press the New button to create a filter
configuration. Provide a name for the filter. Uncheck WBDL Pr obl em XM. Pr obl em XML Schena Pr obl emand XSL Pr obl emin the Types subpanel.
If you created a working set you may want to apply the filter to it. Otherwise select and appropriate scope. Press the Ck button to create the filter.
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C) Use the Eclipse Menu: Window -> Preferences -> Java -> Compiler -> Errors/Warnings and open the Depr ecat ed and Restricted API
dropdown. Set the For bi dden ref erence (access rul es) combo box to War ni ng. Press the Appl y or Ok button to save the settings. This may
start a full rebuild.
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Installing from the Command-Line

. Make sure you have a fresh checkout from Subversion.

. If you have not previously built do it now.

. After a successful build create the installer (or use the - P i nst al | er in the build configuration).

. Copy the installer from the <workspace>/fedora-repository>/installer/target to an install directory.

. Run the installer to create an initial deployment (see the Installation and Configuration Guide). You should use a different directory from your
Eclipse workspace for now. You may choose any configuration but use the Quick install until you have more experience.

. Start and stop the server once to ensure the configuration is correct and the / pat h/ t o/ t ontat / webapps/ f edor a directory is created. This
will permit the installer to set up the initial configuration which is difficult to do manually.
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Known Issues

1. Eclipse creates META-INF/MANIFEST.MF files


https://wiki.lyrasis.org/display/FEDORA37/Installation+and+Configuration

a. https://issues.sonatype.org/browse/MNGECLIPSE-671
b. https://bugs.eclipse.org/bugs/show_bug.cgi?id=285510
c. http://www.nabble.com/New-files-added-to-src-tree-on-Maven-import-td24772549.html

2. New or renamed modules are not updated in Eclipse project layout
a. http://www.nabble.com/New-modules-and-SCM-headaches.-td22167868.html

Related Materials

Building Fedora from Source Video
How do | configure Eclipse to work with pre 3.3 versions of Fedora?

Eclipse with Maven notes
These are the steps | followed to get Fedora building correctly in Eclipse -- Eddie (6 Nov 2009)

Tested with:

® Eclipse 3.4 (Ganymede), Carbon 32-bit & Eclipse 3.5 (Galileo), Cocoa 64-bit
® m2eclipse
® Subversive
0 SVNKit 1.3
O Subversive Integration for the M2Eclipse Project (from http://www.polarion.org/projects/subversive/download/integrations/update-site/ )
® | also needed to update SVN Team Provider using http://download.eclipse.org/technology/subversive/0.7/update-site/ rather
than the one provided by the update site in Galileo

. Add the fedora svn repository to Eclipse (https://fedora-commons.svn.sourceforge.net/svnroot/fedora-commons/fedora)
. Optional: create a new working set for Fedora (e.g. fcrepo)
Checkout trunk as a Maven project (if you created a working set, check out into the working set)
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https://issues.sonatype.org/browse/MNGECLIPSE-671
https://bugs.eclipse.org/bugs/show_bug.cgi?id=285510
http://www.nabble.com/New-files-added-to-src-tree-on-Maven-import-td24772549.html
http://www.nabble.com/New-modules-and-SCM-headaches.-td22167868.html
#
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http://www.polarion.org/projects/subversive/download/integrations/update-site/
http://download.eclipse.org/technology/subversive/0.7/update-site/
https://fedora-commons.svn.sourceforge.net/svnroot/fedora-commons/fedora

4. Update Project Configuration (using the Maven menu) for common and fedora-admin-client projects
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5. Add target, .settings, .classpath, .project to Ignored Resources (Preferences/Team)
6. Java Compiler Errors
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7. Filter Problems

Known Issues
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1. Eclipse creates META-INF/MANIFEST.MF files
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https://issues.sonatype.org/browse/MNGECLIPSE-671

b. https://bugs.eclipse.org/bugs/show_bug.cgi?id=285510

c. http://www.nabble.com/New-files-added-to-src-tree-on-Maven-import-td24772549.html
2. New or renamed modules are not updated in Eclipse project layout

a. http://www.nabble.com/New-modules-and-SCM-headaches.-td22167868.html


https://bugs.eclipse.org/bugs/show_bug.cgi?id=285510
http://www.nabble.com/New-files-added-to-src-tree-on-Maven-import-td24772549.html
http://www.nabble.com/New-modules-and-SCM-headaches.-td22167868.html
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