Page tree

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

Info
titleLatest Releases of Replication Task Suite

Based on the version of DSpace you are running, here are the compatible latest releases of the Replication Task Suite:

  • RTS, version 6.0 - bug-fix release, compatible only with DSpace 6.x and higher releases
    • Upgrading: To upgrade to RTS 6.0 from a previous version, simply change your pom.xml (see Installation on DSpace 6.x) to reference 'dspace-replicate' version 6.0.  Then rebuild DSpace & re-run 'ant update'. You should verify your configurations are still compatible with DSpace 6.0, as the DSpace Configuration System received an overhaul in DSpace 6
      • After upgrading the RTS software, it is recommended to run a full backup to ensure all your AIP packages are also updated (if necessary).
    • 6.0 Bug Fixes: refactored to work with DSpace 6.x (UUIDs instead of integers)
  • RTS, version 3.4 - bug-fix release, compatible with all DSpace 3.x, 4.x and 5.x releases
    • Upgrading: To upgrade to RTS 3.4 from a previous version, simply change your pom.xml (see Installation on DSpace 3.x, 4.x or 5.x) to reference 'dspace-replicate' version 3.4.  Then rebuild DSpace & re-run 'ant update'. Your existing RTS 3.x configuration files will still work with RTS 3.4.
      • After upgrading the RTS software, it is recommended to run a full backup to ensure all your AIP packages are also updated (if necessary).
    • 3.4 Bug Fixes: Updates DuraCloud API to latest version v4.3.9 (to take advantage of recent performance improvements in DuraCloud API). WARNING: Latest version of DuraCloud The DuraCloud API v4.0.0 or greater requires Java 8. So, using RTS 3.4 with DuraCloud would require running DSpace with Java 8.
    • 3.3 Bug Fixes: Updates DuraCloud API to v3.7.4.
    • 3.2 Bug Fixes: Ensures RTS compiles for Java 7 (which is required for RTS 3.x).
    • 3.1 Bug Fixes: Fixes several small bugs (namely with the event consumer utilized during Automatic Replication).  Also ensures RTS runs on the DSpace 3.x platform.
  • RTS, version 1.3 - bug-fix release, compatible with all DSpace 1.8.x releases.
    • Upgrading: To upgrade to RTS version 1.3 from a previous release, simply change your pom.xml (see Installation on DSpace 1.8.x) to reference 'dspace-replicate' version 1.3. Then rebuild DSpace & re-run 'ant update'. Your existing RTS 1.x configuration files will still work with RTS 1.3.
      • After upgrading the RTS software, it is recommended to run a full backup to ensure all your AIP packages are also updated (if necessary).
    • 1.3 Bug Fixes: This fixes a DuraCloud v2.4.0 connection error with version 1.2.
    • 1.2 Bug Fixes: This fixes a Java 6 incompatibility bug in version 1.1.  Previously version 1.1 required Java 7 when using DuraCloud.
    • 1.1 Bug Fixes: Fixes for several small bugs in 1.0 (namely with the event consumer utilized during Automatic Replication).

...